This project is read-only.

SourceBackup seems to stop processing if it finds a symbolic link.

Jul 6, 2016 at 9:44 PM
Edited Jul 6, 2016 at 9:45 PM
SourceBackup seems to stop processing if it finds a symbolic link.

It seems to me that it should just keep going.

For example, the error below occurs when "graphics" is a symbolic link that points to a network share.


Could not find a part of the path 'C:\Users\mkamoski\Source\Repos\feature-foo1-graph\Billy.Web\graphics'.

This is on Window 7 x64.



-- Mark Kamoski
Jul 15, 2016 at 8:37 PM
Edited Jul 15, 2016 at 9:28 PM
Dear SourceBackup Developers and all...

This is an update to my post above, about SourceBackup and symbollic links.

This morning, I ran the SourceBackup, and note the version that I downloaed was "SourceBackupSetup4.3.msi".

As noted in my post above the backup run broke when it hit a symbollic link that was inside a folder in what I was trying to backup there.

The backup just stopped midway through, and did not complete after the crash, when backing up "C:\MyFolder\MyProject\" there, and that folder has a symbollic link in it.

So, this afternoon, I decided to pull down the source code (sourcebackup-89587) and tweak it to skip any symbollic links that it finds, so I got the code.

I loaded the code into Visual Studio 2015 Community, and I ran it in Debug Mode, and I ran it against "C:\MyFolder\MyProject\", and it finished without error, but there was a longish pause where it was reporting "Not Responding" but I waited it out and it just self healed and the result seems OK, though I do admit I did NOT diff and QA the result to be sure it actually got every file it should have, but it SEEMS to have done so as the result ZIP size is more-or-less the same size as when the symbollic link is manually removed from the backup target.

I complied and then ran the EXE with the same target, "C:\MyFolder\MyProject\", and it finished without error.

So, I am now really NOT sure what is going on, and there is (seemingly?) nothing to fix in the source code, so I am just using the EXE that I self-compiled.

SideBar -- SourceBackup would be greater if the "move file dialog" were forced-on-top and forced-modal and force-focused, because sometimes it gets hidden away behind other programs/screens/windows/etc and I have to ALT-TAB to find it and focus to it, but this is just a fine-tuning suggesting

All is well.

Just thought I would let you know.



-- Mark Kamoski
Jul 20, 2016 at 2:05 PM
Edited Jul 20, 2016 at 2:07 PM

Sad news.

My testing above stating that the break-on-symbollic-link is not an issue was wrong-- it IS still broken.

Could not find a part of the path 'C:\Users\MyUser\Source\Repos\MyFeature\MyWeb\MySymbollicLinkFolder'.

If I find time, then I will try to make a fix.


-- Mark Kamoski
Jul 22, 2016 at 4:53 PM
Dear SourceBackup Developer (and all) -- FYI, I uploaded a patch to recently. This patch upload, "", is quick fix for the issue where SourceBackup processing fails when trying to backup a folder that contains a folder-that-is-a-symbolic-link. HTH. Thanks. -- Mark Kamoski
Jul 29, 2016 at 6:43 PM
BTW, do not feel too bad. because Windows 7 itself also chokes/breaks when trying to copy a folder with a symbollic link in it.

As a side note, (trigger warning for an upcoming AI-sucks rant), this is a good example of where so-called computer AI is NOT AI until it can do stuff like this. For a human (me at least) it is ridiculously obvious, I want to copy all files that I can and skip those I cannot. Now, you may say, "well you have to give the computer an instruction to do that so it knows to check for a symbollic link or not and to skip it or not). But, that is exactly my point. The so-called AI has no way of "figuring it out when it gets stuck" in such a case (at least not any computer that I have seen). Instead Windows just sits there forever trying to copy a file that it cannot copy. I suppose this gets back to the "the program has no way of knowing if it will exit" unsolvable problem. But, again, that is just it. A human takes a quick outside peek, sees that a folder will 100mb should not take 1 hour to copy locally, and if it tries for that long it is "stuck" and should "give up". At least. It is going to a a LONG time before the robot revolution. IMHO. End rant.

-- Mark Kmaoski